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Introduction
Swordfish is an advanced CAT (Computer Aided Translation) tool based on Open Standards that
supports MS Office, DITA, HTML and other document formats.

Swordfish uses TM (TranslationMemory) andMT (Machine Translation). Supports segment filtering,
terminology, customization and more.

Supported File Formats
The file formats currently supported by Swordfish are:

• General Documentation Types

– Adobe InCopy ICML

– Adobe InDesign Interchange (INX)

– Adobe InDesign IDML CS4, CS5, CS6 & CC

– HTML

– Microsoft Office (2007 and newer)

– Microsoft Visio XML Drawings (2007 and newer)

– MIF (Maker Interchange Format)

– OpenOffice / LibreOffice / StarOffice

– Plain Text

– SRT Subtitles

• Localization Files

– SDLXLIFF (Trados Studio)

– Trados Studio Packages (*.sdlppx)

– Wordfast/GlobalLink TXML (*.txml)

– Wordfast/GlobalLink XLIFF (*.txlf)

– WPML XLIFF (WordPress Multilingual Plugin)

– XLIFF from Other Tools (*.mqxliff, *.xliff)

• XML Formats

– XML (Generic)

– DITA 1.0, 1.1, 1.2 and 1.3

– DocBook 3.x, 4.x and 5.x

– SVG

– Word 2003 ML

– XHTML

• Software Development Types
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– JavaScript

– Java Properties

– JSON

– PHP Arrays

– RC (Windows C/C++ Resources)

– ResX (Windows .NET Resources)

Note
The filter for XML files supports custom configuration. Users can define conversion
rules for almost any XML vocabulary. See XML Filter Settings chapter formore details.

Supported Platforms
Swordfish works on these Operating Systems:

• Microsoft Windows 10 and 11

• macOS Big Sur (11.0), Monterey (12.0), Ventura (13.0) and Sonoma (14.0)

• Linux (with GNOME Desktop Manager)
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Getting Started
Only a few steps are necessary to translate with Swordfish. The basic workflow for translating
documents is:

1. Setup memories and glossaries

2. Create a project

3. Translate a project

4. Export translations

Step 1: Setup Memories and Glossaries
Swordfish uses TranslationMemory (TM) technology to assist translators. It stores your translations
inMemories and offers them again when you need to translate a similar text.

1. Create aMemory to store your translations, following the steps described in the AddMemory
section.

2. If you have TranslationMemory data in TMX format, import your TMX files into yourmemories
following the procedure indicated in the Import Translation Memory Data section.

Use Glossaries to store frequent terms and their translations for consulting at translation time.
Your glossary entries can also assist in assembling matches with the Auto-Translation engine
included in Swordfish.

1. Create aGlossary to store your terms, following the instructions from the AddGlossary section.

2. If you have terminology data in TMX or TBX format, import your data into your glossaries
followingthe procedure indicated in the Import Glossary Data section.

Note
You can reuse memories and glossaries in different translation projects. It is not
required to create a new memory or glossary at the start of each project.

Step 2: Create a Project
Swordfish allows you to translate one or more files at a time. Translation tasks are organized as
Projects.

There are two methods for creating projects:

• Translate Single File: use this simplified method for creating a project containing just one file.

• Add Project: use this option when you want to translate several related documents together.

When you create a project from a single file, the file name and location are used as project name.
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Step 3: Translate a project
Follow the instructions from the Translate Project section and translate all segments contained
in your project.

Notice the features listed in the Common Tasks chapter. They provide useful functionality to carry
on with the translation task.

Step 4: Export translations
Once you have finished translating your project, follow the steps described in the Export
Translations section.
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Projects
Swordfish organizes your translation tasks in Projects, where a project is a set of files to be
translated together.

The Projects tab in Swordfish lists your translation projects and offers direct access to these
project-related operations from its toolbar:

• Translate Single File

• Add Project

• Translate Project

• Export Translations

• Project Statistics

• Export HTML

• Export as XLIFF 2.0

• Update from XLIFF File

• Remove Project

• Export Project

• Import Project

Translate Single File
Follow these steps to create a translation project from a single file.

Procedure
1. Select the file to translate:

• Select File → Open... ([Ctrl+O] onWindows/Linux, [Cmd+O] onmacOS) from themainmenu
or click the button on the toolbar of the Projects tab. Use the dialog displayed by the
Operating System to select a file.

• Drag a file and drop it in the Projects tab.

Once you have selected a file, the Translate File dialog appears:
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2. Complete the fields of the Translate File dialog:

a. If Swordfish has not detected the right document , select it using the File Type drop-down
.

b. if Swordfish has not detected the character set for the document automatically, select it
using the Character Set drop-down

c. Select the source language of your project using the Source Language drop-down.
d. Select the target language of your project using the Target Language drop-down.
e. Optionally, enter a subject description for the new project in the Subject box, or select

an existing value from the drop-down list.
f. Optionally, enter a client name for the new memory in the Subject box, or select an

existing value from the drop-down list.

a. Optionally, select a memory for storing your translations using the Default Memory
drop-down.

b. Optionally, select the Apply Translation Memory checkbox to incorporate Translation
Memory matches from Default Memory into your project.

c. Optionally, select a glossary for checking terms at translation time using the Default
Glossary drop-down.

d. Optionally, select the Search Terms checkbox for fetching all known terms from the
Default Glossary before starting the translation task.

3. Click the Translate File button.

Results
A project creation process is started. Once the project is ready, it is opened for translation.

Add Project
A Swordfish project may contain one or more files. Follow these steps to create a project with
several files.

Procedure
1. Select Projects → NewProject ([Ctrl+N] onWindows/Linux, [Cmd+N] onmacOS) from themain

menu or click the button on the toolbar of the Projects tab.

The New Project dialog appears:
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2. Complete the fields of the New Project dialog:

a. Enter a descriptive name for the project in the Name text box.
b. Select the source language of your project using the Source Language drop-down.
c. Select the target language of your project using the Target Language drop-down.
d. Optionally, enter a subject description for the new project in the Subject box, or select

an existing value from the drop-down list.
e. Optionally, enter a client name for the new memory in the Subject box, or select an

existing value from the drop-down list.
f. Optionally, select a memory for storing your translations using the Default Memory

drop-down.
g. Optionally, select the Apply Translation Memory checkbox to incorporate Translation

Memory matches from Default Memory into your project.
h. Optionally, select a glossary for checking terms at translation time using the Default

Glossary drop-down.
i. Optionally, select the Search Terms checkbox for fetching all known terms from the
Default Glossary before starting the translation task.

3. Click the Add Files button to select the files to translate using a dialog from the Operating
System.

Make sure that the File Type and Character Set drop-downs display the right selection for
each file. Adjust their values as needed.

4. If you want to remove one or more files from the list, select the checkbox from the leftmost
column and click the Delete Selected Files button.

5. Click the Create Project button.
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Results
A project creation process is started. Once the project is ready, it is opened for translation.

Translate Project
New projects are opened automatically for translation. To continue work on a closed project:

1. In Projects tab, click the project that you want to translate.

2. Select Projects → Translate Projects from themainmenu or click the button on the toolbar
of the Projects tab.

Note
You can also double-click on a project in the Projects tab to open it for translation.

A project opened for translation looks like this:

The translation view has these special areas:

Contains an array of buttons for performing different tasks. It also
contains drop-down selectors for the active and glossary.

Top Toolbar

Large scrollable table of segments, showing source text, segment
status and translation.

Translation Panel

Located on the right side, this section holds three panels: Translation
Memory,Machine Translation and Terms.

Side Panel

Located at the bottom, this area contains buttons for navigating
between project pages and provides translation status information.

Navigation and Status
Bar

Click on a segment to start translating it. The corresponding row is highlighted and centered on
screen (whenever possible) and the cursor is positioned at the start of target text.
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Source formatting is represented with greenmarks containing a number (i.e.: 3 ). To insert green
marks, also known as inline tags, press [Ctrl+N] on Windows/Linux, ([Cmd+N] on macOS) where N

is the number in the mark. You can also use the different options for managing tags from Edit
menu:

• Edit → Insert Tag ([Ctrl+T] on Windows/Linux, [Cmd+T] on macOS): displays a window for
writing the tag number. Use this option when the number is greater than 10.

• Edit → Insert Tags...: opens a submenu for inserting tags 1 to 10.

• Edit → InsertNext Tag ([Ctrl+Shift+T] onWindows/Linux, [Cmd+Shift+T] onmacOS): inserts
the tag that follows the highest tag number inserted so far.

• Edit → Insert Remaining Tags ([Ctrl+Alt+T] on Windows/Linux, [Cmd+Alt+T] on macOS):
inserts all tags from source that are not present in target text.

• Edit → Remove All Tags ([Ctrl+Shift+R] on Windows/Linux, [Cmd+Shift+R] on macOS):
removes all tags present in target text.

Note
In case there are tag errors or initial/trailing spaces errors in a segment, a warning
icon ( ) is displayed in the center columnof the TranslationPanelwhen the segment
is confirmed.

When the segment is fully translated, press [Ctrl+E] ([Cmd+E] on macOS) or click the button on
the top toolbar to confirm it. When you confirm a segment, its translation is stored in thememory
selected in theMemory drop-down of the top toolbar and is also automatically propagated to all
similar unconfirmed segments.

You have two more options for marking a segment as confirmed:

• Press [Alt+Down Arrow] ([Ctrl+Alt+Down Arrow] on macOS) or click the button on the top
toolbar to Confirm and go to Next Untranslated segment.

• Press [Alt+Shift+Down Arrow] ([Ctrl+Shift+Down Arrow] onmacOS) or click the button on
the top toolbar to Confirm and go to Next Unconfirmed segment.

Use [Page Up] and [Page Down] keys to move to next and previous segments and translate them.

When all segments have been translated, on main menu select Projects → Export HTML([F5]) or
click on the button on the top toolbar to export an HTML version of your translations for review.
Note any segments with errors and correct them.

To visit a segment knowing its number, in main menu selectEdit → Go To Segment..., click on the
or press [Ctrl+G] ([Cmd+G] on macOS). The Go To Segment dialog appears:
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Type the number of the segment you want to review in the Segment Number box and click the
Go To Segment button.

Finally, use the Check Inline Tags [F9] and Check Initial/Trailing Spaces [F10] options from QA
menu to check that your file is properly translated. Pay special attention to errors in tags, because
the translated document may become unusable.

Export Translations
Follow these steps to generate translated versions of all files in a project.

About this task
Once all segments have been translated and reviewed, generate the translated version of your
project.

Procedure
1. Select Projects → Export Translations ([Alt+Ctrl+S] on Windows/Linux, [Alt+Cmd+S] on

macOS) from the main menu or click the button on the toolbar of the Projects tab or the
top toolbar of a translation tab.

The Operating System will display a dialog for selecting where to save the translated
documents.

Results
After your translations are exported, a new dialog will offer to open the translated file or folder.

Project Statistics
Follow these steps to generate an statistic report from a project.

About this task
Knowing the number of segments, words and available TM matches in a project is essential to
estimate the cost of a translation job.

Swordfish statistic analysis generates word counts and segment counts at file and project levels,
including the availability of Translation Memory matches at different ranges.

Procedure
1. Select Projects → Project Statistics from the main menu or click the on the toolbar of the

Projects tab or the top toolbar of a translation tab.
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Results
An HTML file containing projects statistics is generated and automatically opened in the default
web browser.

Export HTML
Follow these steps to export your project as an HTML file for review.

Procedure
1. Select Projects → Export HTML ([F5]) from the main menu or click the on the toolbar of

the Projects tab or the top toolbar of a translation tab.

Results
An HTML view of all segments is generated and automatically opened in the default web browser.

Export as XLIFF 2.0
Follow these steps to export a project for translation or review in a tool that supports the XLIFF
2.0 standard.

About this task
• Use this option to share the contents of a project for translation or review with colleagues
using tools that support XLIFF 2.0.

• Use the Update from XLIFF File option to update the project with the translated or reviewed
content.

Note
The exported XLIFF file cannot be used to create translated versions of the documents
in the project.

Procedure
1. On the Projects tab, select the project that you want to export by clicking on it.

2. SelectProjects → Export as XLIFF 2.0 from themainmenu or click the button on the toolbar
of the Projects tab.

The operating system displays a dialog for selecting the name and location of the XLIFF file
to be created.

Results
An export process is started and an export indicator is displayed until an XLIFF file is created.

Update from XLIFF File
Follow these steps to update a project using the translations in an XLIFF file.
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About this task
After exporting a project as XLIFF 2.0 for translation or review, use this option to update the content
of the project with the content of the processed XLIFF file.

Procedure

1. Select Projects → Update from XLIFF File from the main menu or click on the button on
the toolbar of the Projects tab.

The operating system displays a dialog for selecting the name and location of the XLIFF file
to process.

Results
An import process is started and an import indicator is displayed until the update process is
complete.

Remove Project
Follow these steps to permanently remove a Project from Swordfish.

Procedure
1. In Projects tab, select all projects that you want to remove by clicking on them.
2. Select Project → Remove Projects from the main menu or click the button on the toolbar

of the Projects tab.
3. Confirm projects removal in the dialog that is displayed.

Export Project
Follow these steps to export a project as XLIFF 2.0 file.

About this task
Export projects as XLIFF 2.0 files for backup purposes or to continueworking in a different computer
that has Swordfish.

Note
Exported XLIFF files contain everything required to generate translated versions of
the documents contained in the project on any computer using Swordfish, Open
XLIFF Filters or XLIFF Manager.

Procedure
1. On the Projects tab, select the project that you want to export by clicking on it.

2. Select Projects → Export Project from the main menu or click the button on the toolbar
of the Projects tab.

The operating system displays a dialog for selecting the name and location of the XLIFF file
to create.
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Results
An export process is started and an export indicator is displayed until the process is complete.

Import Project
Follow these steps to create a new project from an XLIFF 2.0 project file exported by Swordfish.

About this task
Use this option to import a projet created by Swordfish in another computer. or for importing a
project file from Swordfish that has been processed using a different tool.

Procedure

1. SelectProjects → Import Project from themainmenu or click on the button on the toolbar
of the Projects tab.

The Import Project File dialog is displayed:

2. Enter a descriptive name for the project in the Project Name text box.

3. Type the name of the XLIFF file to import in the Project File text box or click the Browse...
button next to it to select an XLIFF file from the file system.

4. Optionally, enter a subject description for the new project in the Subject box, or select an
existing value from the drop-down list.

5. Optionally, enter a client name for the new project in the Client box, or select an existing
value from the drop-down list.

6. Click the Import Project File button.
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Memories
Swordfish stores your translations inMemories for later reuse.

TheMemories tab in Swordfish lists your translation memories and offers direct access to these
memory-related operations from its toolbar:

• Add Memory

• Remove Memory

• Import TMX File

• Export Memory as TMX File

• Concordance Search

• Add RemoteTM Memory

Note
Export your memories as TMX files frequently and save the TMX files in a safe place
as backup.

Add Memory
Follow these steps to create a Memory for storing your Translation Memory (TM) data.

Procedure
1. SelectMemories → Add Memory from the main menu or click the button on the toolbar

of theMemories tab.

The Add Memory dialog appears:

2. Type a descriptive name for the new memory in the Name text box.

3. Optionally, enter a project description for the new memory in the Project box, or select an
existing value from the drop-down list.

4. Optionally, enter a subject description for the new memory in the Subject box, or select an
existing value from the drop-down list.
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5. Optionally, enter a client name for the new memory in the Subject box, or select an existing
value from the drop-down list.

6. Click the Add Memory button to create a new memory.

Add RemoteTM Memory
Follow these steps to add a memory hosted on a RemoteTM server instance to Swordfish.

About this task

Procedure
1. SelectMemories → Add RemoteTM Memory from the main menu or click the button on

the toolbar of theMemories tab.

The RemoteTM Server dialog appears:

2. Type the RemoteTM server address in the Server URL text box.

3. Enter your RemoteTM username in the Username text box.

4. Type your RemoteTM password in the Password text box.

5. Click the Browse Server button.

The RemoteTM Server dialog appears:

6. Select one or more memories. To select more than one memory, keep the Ctrl key (CMD on
macOS) pressed while you click on the desired rows.
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7. Click the Add Memory button.

Results
On success, selected memories are added to the memories list.

Import Translation Memory Data
Follow these steps to import Translation Memory Data from TMX files into Swordfish memories.

Procedure
1. In theMemories tab, select the memory into wich you want to import a TMX file by clicking

on it.

2. SelectMemories → Import TMXFile from themainmenuor click the button on the toolbar
of theMemories tab.

The Import TMX File dialog appears:

3. Type the name of the TMX file to import in the TMX File text box or click the Browse... button
next to it to select a TMX file from the file system.

4. Optionally, enter a project description for the TMX data in the Project box, or select an existing
value from the drop-down list.

5. Optionally, enter a subject description for the TMXdata in the Subject box, or select an existing
value from the drop-down list.

6. Optionally, enter a client name for the TMX data in the Client box, or select an existing value
from the drop-down list.

7. Click the Import TMX File button.

Results
An import process is started. The number of imported entries is displayedwhen the import process
completes.

Export Memory Data
Follow these steps to export the content of your memories to TMX files
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About this task
Export your Translation Memory data as TMX files regularly and keep a copy of the exported TMX
as backup.

Procedure
1. In theMemories tab, select the memory that you want to export as a TMX file by clicking on

it.

2. SelectMemories → Export Memory as TMX File from the main menu or click the button
on the toolbar of theMemories tab.

The operating system displays a dialog for selecting the name and location of the TMX file to
create.

Results
An export process is started and an export indicator is displayed until the process is complete.

Remove Memory
Follow these steps to permanently remove a Memory from Swordfish.

Procedure
1. In theMemories tab, select all memory that you want to remove by clicking on them.
2. SelectMemories → Remove Memory from the main menu or click the button on the

toolbar of theMemories tab.
3. Confirm memories removal in the dialog displayed by the Operating System.
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Glossaries
Swordfish stores your terminology data in Glossaries.

TheGlossaries tab in Swordfish lists your glossaries and offers direct access to these terms-related
operations from its toolbar:

• Add Glossary

• Remove Glossary

• Import Glossary

• Export Memory as TMX File

• Add Term to Glossary

• Search Term in Glossary

• Add RemoteTM Glossary

Note
Export your glossaries as TMX files frequently and save the TMX files in a safe place
as backup.

Add Glossary
Follow these steps to create a Glossary for storing your terminology data

Procedure
1. Select Glossaries → Add Glossary from the main menu or click the button on the toolbar

of the Glossaries tab.

The Add Glossary dialog appears:

2. Type a descriptive name for the new glossary in the Name text box.

3. Optionally, enter a project description for the new glossary in the Project box, or select an
existing value from the drop-down list.

4. Optionally, enter a subject description for the new glossary in the Subject box, or select an
existing value from the drop-down list.
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5. Optionally, enter a client name for the new glossary in the Subject box, or select an existing
value from the drop-down list.

6. Click the Add Glossary button to create a new glossary.

Add RemoteTM Glossary
Follow these steps to add a glossary hosted on a RemoteTM server instance to Swordfish.

About this task

Procedure
1. Select Glossary → Add RemoteTM Glossary from the main menu or click the button on

the toolbar of the Glossaries tab.

The RemoteTM Server dialog appears:

2. Type the RemoteTM server address in the Server URL text box.

3. Enter your RemoteTM username in the Username text box.

4. Type your RemoteTM password in the Password text box.

5. Click the Browse Server button.

The RemoteTM Server dialog appears:

6. Select one or more glossaries. To select more than one glossary, keep the Ctrl key (CMD on
macOS) pressed while you click on the desired rows.
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7. Click the Add Glossary button.

Results
On success, selected glossaries are added to the glossaries list.

Import Glossary Data
Follow these steps to import glossary data from TMX or TBX files into Swordfish glossaries.

About this task
Swordfish allows importing terminology data into Glossaries from TMX and TBX files. Two TBX
versions are supported:

• TBX version 2, also known as ISO 30042:2008, originally released in 2002 by LISA's OSCAR
special interest group.

• TBX version 3, also known as ISO 30042:2019, latest release from ISO.

Procedure
1. In theGlossaries tab, select the glossary intowich youwant to import a glossary file by clicking

on it.

2. Select Glossaries → Import Glossary from the main menu or click the buttom on the
toolbar of the Glossaries tab.

The Import Glossary File dialog appears:

3. Type the name of the file to import in the Glossary File text box or click the Browse... button
next to it to select a TMX or TBX file from the file system.

4. Optionally, enter a project description for the glossary data in the Project box, or select an
existing value from the drop-down list.

5. Optionally, enter a subject description for the glossary data in the Subject box, or select an
existing value from the drop-down list.

6. Optionally, enter a client name for the glossary data in the Client box, or select an existing
value from the drop-down list.

7. Click the Import Glossary File button.

20Glossaries

Swordfish User Guide



Results
An import process is started. The number of imported entries is displayedwhen the import process
completes.

Export Glossary Data
Follow these steps to export the content of your glossaries to TMX files

About this task
Export your glossary data as TMX files regularly and keep a copy of the exported TMX as backup.

Procedure
1. In the Glossaries tab, select the glossary that you want to export as a TMX file by clicking on

it.

2. SelectMemories → Export Glossary from themainmenu or click the button on the toolbar
of the Glossaries tab.

The operating system displays a dialog for selecting the name and location of the TMX file to
create.

Results
An export process is started and an export indicator is displayed until the process is complete.

Remove Glossary
Follow these steps to permanently remove a Glossary from Swordfish.

Procedure
1. In the Glossaries tab, select all glossaries that you want to remove by clicking on them.
2. Select Glossaries → Remove Glossary from the main menu or click the button on the

toolbar of the Glossaries tab.
3. Confirm glossaries removal in the dialog displayed by the Operating System.

Add Term to Glossary
Follow these steps for storing a term pair in a glossary.

About this task
You can add term pairs to a glossary while translating a project or from the Glossaries tab.

Procedure
1. If you are adding a term from a translation tab, make sure a glossary is selected in the

Glossary drop-down.
•

• If you are adding a term from the Glossaries tab, select a glossary for storing the term.
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2. Select Glossaries → Add Term to Glossary ([Ctrl+B] on Windows/Linux, [Cmd+B] on macOS)
from the main menu or click the button on the toolbar of the Glossaries tab or the
translation tab top toolbar.

The Add Term to Glossary dialog is displayed:

3. Type source term in the Source Term text box.

4. Select the language of source term using the Source Language drop-down.

5. Type target term in the Target Term text box

6. Select the language of target term using the Target Language drop-down.

7. Click the Add Term button.
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Common Tasks
Common tasks usually performed while translating are:

• Concordance Search

• Search Term in Glossary

• Filter Segments

• Sort Segments

• Split Segment

• Merge Segments

• Replace Text

• Edit Source Text

• Pseudo-Translation

Concordance Search
A concordance search allows you to search for a given text in one or more Memories.

About this task
You can search for text while translating a project or from theMemories tab.

Procedure
1. If you are searching froma translation tab,make sure amemory is selected in theMemory

drop-down.
•

• If you are searching from theMemories tab, select one ormorememories for performing
the search.

To select more than one memory inMemories tab, hold the [Ctrl] key ([Cmd] key on macOS)
while clicking on the memories of your interest

2. SelectMemories → Concordance Search ([Ctrl+Y] on Windows/Linux, [Cmd+Y] on macOS)
from themainmenuor click the button on the toolbar of theMemories tab or the translation
tab top toolbar.

The Concordance Search dialog appears:
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3. Type the text to search in the Text to Search text box.

If you are searching from a translation tab, you can select text in source or target columns,
press [Ctrl+Y] ( [Cmd+Y] on macOS) and the text will be automatically added to the Text to
Search text box.

4. Select the language to use when performing the search using the Language drop-down.

Language value is automatically adjusted if the Concordance Search dialog is opened with
a keyboard shortcut after selecting source or target text in a translationt tab.

5. Select the maximum number of entries to display in the Entries to Display drop-down.

6. Optionally, select the Case Sensitive Search checkbox if you want to search only for entries
that exactly match the text entered on the Text to Search text box.

7. Optionally, select the Regular Expression checbox if the text entered in the Text to Search
box should be treated as a regular expression for searching.

8. Click the Search Text button

Results
A search is performed in the selected memories and results are displayed in a dialog like this:

Search Term in Glossary

About this task
You can search terms while translating a project or from the Glossaries tab.

Procedure
1. If you are searching froma translation tab,make sure a glossary is selected in theGlossary

drop-down.
•

• If you are searching from theGlossaries tab, select a glossary for performing the search.

2. SelectGlossaries → Search Term in Glossay ([Ctrl+D] onWindows/Linux, [Cmd+D] onmacOS)
from the main menu or click the button on the toolbar of the Glossaries tab or the
translation tab top toolbar.

The Term Search dialog is displayed:
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3. Type the term to search in the Term text box.

4. Select the language to use when performing the search using the Language drop-down.

5. Select the minimum similarity porcentage to use when searching using the Similarity
drop-down.

6. Optionally, select the Case Sensitive Search checkbox if you want to search only for entries
that exactly match the text entered on the Term text box.

7. Click the Search Term button.

Results
On success, a dialog containing a list of matching results is displayed.

Filter Segments
Follow these steps to filter segments and view only those segments that contain a given text.

About this task
Use segment filtering to find segments containing text that you want to edit.

Procedure
1. Select View → Filter Segments ([Ctrl+F] on Windows/Linux, [Cmd+F] on macOS) from the

main menu or click the button from the top toolbar.

The Filter Segments dialog appears:

25Common Tasks

Swordfish User Guide



2. Type the text to search in the Text to Search text box.

3. Select where to search by checking either Source or Target radio buttons.

4. Optionally, select the Case Sensitive Search checkbox if you want to search only for entries
that exactly match the text entered on the Text to Search text box.

5. Optionally, select the Regular Expression checkbox if the text entered in the Text to Search
box should be treated as a regular expression for searching.

6. Choose the types of segments to include in filtered results, by selecting/deselecting the
checkbox for Untranslated Segments, Translated Segments or Confirmed Segments.

7. Click the Filter Segments button.

Results
Translation view is updated, displaying only segments that contain the filtered text. Filtering
remains active until the Filter Segments dialog is reopened and the Clear Filter button is clicked.

Sort Segments
Follow these steps to sort segments on source/target text or on segment translation status.

About this task
Sometimes you may need to sort segment on text content for review. A common case is the need
to review segments that contain numbers.

It is also convenient to sort segments according to translation status when you want to keep all
untranslated or unconfirmed segments together.

Procedure
1. Select View → Sort Segments ([F3]) from the main menu or click the button on the top

toolbar.

The Sort Segments dialog is displayed:
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2. Select how to sort segments

• Choose Sort on Column Text Content if you want to sort segments on Source Column
or Target Column text.

• Choose Sort on Segment Status if youwant to sort segments according to their translation
status: Translated, Untranslated and Confirmed.

3. Optionally, select the Sort Descending checkbox if you want to sort segments in reverse
order.

4. Click the Sort Segments button.

Results
Translation view is updated, displaying segments in the requested order. Sorting remains in effect
until the Sort Segments dialog is reopened and the Clear Sorting button is clicked.

Split Segment
Folow these steps to split a segment in two at translation time.

About this task

Procedure
1. In a projects translation tab, select the segment that you want to split.

2. Select Edit → Split Segment ([Ctrl+H] on Windows/Linux, [Cmd+H] on macOS) from the main
menu or click the button on the top toolbar.

Source text is selected and highlighed in a different color.

3. Place the cursor at the point where you want to split the segment.

4. Press [Enter].

Results
On success, the segment is split at the selected point and the screen is updated to reflect the
changes.
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Merge With Next Segment
Follow these steps to merge two conscutive segments at translation time.

About this task
Sometimes you may want to merge two consecutive segments to correct a segmentation error
or to produce a translation that would be better rearranging text.

You can merge segments that belong to the same paragraph. Segments that can be merged are
displayed with the same border color in the number column, as shown in the following picture:

Procedure
1. In a project transation tab, select the first of the two segments that you want to merge.
2. Select Edit → Merge With Next Segment ([Ctrl+J] on Windows/Linux, [Cmd+J] on macOS)

from the main menu or click the button on the top toolbar.

Results
On success, selected segment is merged with the following one and the screen is updated to
reflect the merge.

Replace Text
Follow these steps to replace all appearances of a given text with a different text in all segments.

Procedure
1. Select Edit → Replace Text ([Alt+Ctrl+F] on Windows/Linux, [Alt+Cmd+F] on macOS) from

the main menu or click the button on the top toolbar.

The Replace Text dialog is displayed:
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2. Type the text to be replaced in the Text to Search text box.

3. Type the replacement text in the Replace With text box.

4. Optionally, select the Case Sensitive Search checkbox if you want to search only for entries
that exactly match the text entered on the Text to Search text box.

5. Optionally, select the Regular Expression checkbox if the text entered in the Text to Search
box should be treated as a regular expression for searching.

6. Click the Replace Text button.

Edit Source Text
Follow these steps to edit the source text of a segment.

About this task
When source text contains errors, you may want to correct them to ensure that your memories
contain accurate translations.

Procedure
1. Select the segment you wish to edit.

2. Select Edit → Edit Source Text from the main menu or press [Alt+F2].

The background color of segment source changes and text becomes editable.

3. Make all required changes

Avoid reordering or removing tags. If changes in tags are made, it may not be possible to
export translations from the project.

4. At any time:

• Press the [Escape] key to discard all changes.

• Press [Alt+Enter] to save your changes, remaining in current segment.

• Click on another segment to save your changes and continue editing the selected segment.

Pseudo-translation
Use pseudo-translation to simulate the process of translating text into another language.

About this task
Pseudo-translation provides a quick way to test your translation process. Pseudo-translation, also
known asmock translation, is typically used to test if an application can correctly handle translated
text.

Swordfish pseudo-translation replaces all vowels in source text with accented vowels in target
text.

Procedure
1. Select Tasks → Pseudo-translate Untranslated Segmentsfrom the main menu.
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Results
Targets of all untranslated segments are populated with a copy of source text that has all regular
vowels replaced with accented versions.
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Machine Translation
Swordfish supports six Machine Translation (MT) engines:

• Azure Translator Text

• DeepL API

• ChatGPT

• Google Cloud Translation

• ModernMT

• Yandex Translate API

Using Machine Translation is a two-step process:

1. Configure Machine Translation engines options.

2. Request the translation of individual segments or the complete file at translation time.

Machine Translation Settings

About this task
Follow these steps to configure the credentials used when requesting Machine Translations.

Procedure
1. On macOS, select Apple → Preferences → Settings on the menu or press [Cmd + ,].•

• On Windows or Linux main menu, select Settings → Preferences.

The Preferences dialog appears:

2. Select theMachine Translation tab.

• Select Google tab to configure Google Cloud Translation engine. Preferences dialog
switches to:
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a. Check the Enable Google Cloud Translation box.

b. Enter your API Key in the API Key text box.

Note
You can get your personal API Key at Google's Cloud PlatformConsole.

c. Select a source language from the Source Language drop-down.

d. Select a target language from the Target Language drop-down.

e. Check the Use Neural Machine Translation (NMT> box if you want to request NMT
based translations from Google.

• SelectMicrosoft Azure tab to configure Azure Translator Text engine. Preferences dialog
switches to:

a. Check the Enable Azure Translation Text API box.

b. Enter your API Key in the API Key text box.

To obtain an API Key for Azure Translation Text API:
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1. Create an account at http://www.azure.com/.

2. Login at the Azure Portal at https://portal.azure.com/

3. On the Azure dashboard, click the + Create a Resource button to create a new
service account.

4. Click the See all link next to Azure Marketplace.

5. Type Cognitive Services in the Search box and press Enter.

6. Select Translator in search results.

7. Clict the Create button in the Translator page.

8. Complete the form and click the Review + create button.

9. Wait for the account to be created (youwill receive confirmation emails) and then
login again at the Azure Portal.

10. Click on All resources and then select your Translator service account from the
list of resources.

11. You will find your new API keys in the Keys and Endpoint section.

c. Select a source language from the Source Language drop-down.

d. Select a target language from the Target Language drop-down.

• Select Yandex tab to configure Yandex Translate API engine. Preferences dialog switches
to:

a. Check the Enable Yandex Translate API box.

b. Enter your API Key in the API Key text box.

Note
You can create an API Key for Yandex Translate service at
https://cloud.yandex.com/en/docs/iam/operations/api-key/create.

c. Select a source language from the Source Language drop-down.
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d. Select a target language from the Target Language drop-down.

• Select DeepL tab to configure DeepL API engine. Preferences dialog switches to:

a. Check the Enable DeepL API box.

b. Enter your API Key in the API Key text box.

To obtain an API Key for DeepL:

– Visit https://www.deepl.com/translator and create an account.

– Check your Account settings and get or create a key in the Authentication Key
for DeepL API box.

c. Select a source language from the Source Language drop-down.

d. Select a target language from the Target Language drop-down.

• Select ChatGPT tab to configure ChatGPT engine. Preferences dialog switches to:

a. Enter your API Key in the API Key text box.

To obtain an API Key for ChatGPT:

1. Register a user account at https://chat.openai.com/.

2. Create an API Key at https://platform.openai.com/account/api-keys.
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Note
ChatGPT supports, in theory, translating from any language to any
language. Project languages are automatically used for requesting
translations.

• SelectModernMT tab to configure ModernMT engine. Preferences dialog switches to:

a. Check the Enable ModernMT box.

b. Enter your API Key in the API Key text box.

You can register for a user account at
https://www.modernmt.com/pricing/#translators. An API keywill be provided during
registration.

c. Select a source language from the Source Language drop-down.

d. Select a target language from the Target Language drop-down.

3. Click on the Save Preferences button to save your changes.

Translating Segments with MT
You can use Machine Translation (MT) to translate individual segments or to translate all
unconfirmed segments of a project as one operation.

Note
Machine Translation Engines configuration must be completed before requesting
MT translations.

Translate a Single Segment with MT
1. Open a project for translation.

2. Select the segment to translate.
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3. Select Tasks → Get Machine Translations ([Ctrl+L] on Windows/Linux, [Cmd+L] on macOS)
from the main menu or click the button from theMachine Translation panel.

A translation request is sent to all enabled Machine Translation engines. Results are displayed in
theMachine Translation panel.

Translate All Segments with MT
1. Open a project for translation.

2. Select Tasks → Apply Machine Translations to All Segments from the main menu.

A translation request for each unconfirmed segment is sent to all enabled Machine Translation
engines. Results are displayed in theMachine Translation panel.

Managing Machine Translation Results
• Whenmore than one result is available in theMachine Translation panel, tab labels indicate
translation origin.

Click on the tab label to view the corresponding result or use the following commands to view
them using the keyboard:

macOS ShortcutsWindows/Linux
Shortcuts

Menu Options

[Ctrl+Alt+Right Arrow][Alt+Right Arrow]View → Next Machine Translation
Match

[Ctrl+Alt+Left Arrow][Alt+Left Arrow]View → PreviousMachineTranslation
Match

• To copy a Machine Translation match to the target of the selected segment, select Tasks →
Accept Machine Translation in main menu ([Alt+Ctrl+L] on Windows/Linux, [Alt+Cmd+L]
on macOS) or click the button in theMachine Translation panel.

• To insert aMachine Translationmatch in the target of all unconfirmed segments, select Tasks
→ Accept All Machine Translations from main menu.

Note
When there are multiple Machine Translations in a segment, the first one
available is copied to target.

• Select Tasks → RemoveAllMachine Translations inmainmenu if youwish to remove existing
MT matches from all segments of the selected project.
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Auto-Translation
Auto-Translation assembles translations combining fragments from Translation Memory results
and Glossary entries.

When the difference between source text and the source tex of a match from a Memory is a
number or a term available in the active Glossary, Auto-Translation repairs the match adjusting
the number or term.

In cases where there is no match to repair but there are terms in the active Glossary,
Auto-Translation provides a partial Machine Translation based on Glossary terms.

The operations you can do with Auto-Translation are:

• Get Auto-Translations

• Apply Auto-Translation to All Segments

• Remove All Auto-Translations

Get Auto-Translations
Follow these steps to apply Auto-Translation to an individual segment.

About this task
Make sure that a Memory and a Glossary are selected in the corresponding drop-downs of the
top toolbar.

Procedure
1. Select Tasks → Get Auto-Translations ([Ctrl+R] on Windows/Linux, [Cmd+R] on macOS) from

the main menu or click the button on the Machine Translation panel.

Results
On success, a match is added to theMachine Translation panel and fixed differences are
highlighted like in this example:

Apply Auto-Translation to All Segments
Follow these steps to apply Auto-Translation to all segments of a project.

About this task
Make sure that a Memory and a Glossary are selected in the corresponding drop-downs of the
top toolbar.
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Procedure
1. Select Tasks → Apply Auto-Translation to All Segments from the main menu.

Results
Auto-Translation is applied to all segments and current current segment is updated to display the
result, if available.

Remove All Auto-Translations
Follow these steps to remove Auto-Translation from all segments of a project.

About this task

Procedure
1. Select Tasks → Remove All Auto-Translations from the main menu.

A confirmation dialog is displayed.

Results
After confirming the removal request, all existing Auto-Translations in the project are removed
and current segment is updated to reflect the changes.
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Quality Assurance
Performing Quality Assurance checks is a way of preventing mistakes and avoid problems when
delivering a translated document.

Swordfish highligts spelling errors while you type. Correct spelling errors, if any, before confirming
a segment.

After translating all segments in a project, it is recommended to perform these actions:

• Export translations as HTML for review. Note all errors and edit segments as required.

• Check inline tags.

• Check initial and trailing spaces.

Inline Tags
Follow these steps to validate inline tags in a project

About this task
Always verify that inline tags are correct before exporting translations. If there are tag errors,
exported translated documents may be unusable.

Procedure
1. SelectQA → Check Inline Tags ([F9]) from the main menu or click the button from the top

toolbar.

The Tag Analysis dialog is displayed:

2. If there are tag errors, double-click on any segment from the list to open it for fixing. You can
also open a segment for editing by clicking on it and then on the Open Selected Segment
button.

3. Use the Refresh List button to update the list of segments after you fix them.

Initial/Trailing Spaces
Follow these steps to validate initial and trailing spaces in a project
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About this task
Initial and trailing spaces are highlighted in source and target columns of the Translation Panel
table to make it easier to spot them. Check that spaces are properly transfered to target text to
avoid formatting issues in translated documents.

Note
Checking spaces may not be necessary when working with Asian target languages.

Procedure
1. Select QA → Check Initial/Trailing Spaces ([F10]) from the main menu or click the button

from the top toolbar.

The Space Analysis dialog is displayed:

2. If there are space errors, double-click on any segment from the list to open it for fixing. You
can also open a segment for editing by clicking on it and then on theOpen Selected Segment
button.

3. Use the Refresh List button to update the list of segments after you fix them.
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Spellchecker
Swordfish automatically spellchecks your text as you type.

On macOS, Swordfish uses the native spellcheking API provided by the Operating System. By
default, macOS tries to guess your writing language and may not provide accurate spellcheking.
You can configure macOS to use a specific language following the steps from the Spellchecking
on macOS section.

On Windows and Linux, Swordfish uses Hunspell dictionaries from the Chromium project.
Dictionaries are downloaded automatically by the programwhen they are available for the selected
target language.

If your target language is English, Spanish or Portuguese, youneed to tell Swordfishwhich language
variant to use for spellchecking, following the steps from the Spellchecking onWindows and Linux
section.

Spellchecking on macOS
On macOS, Swordfish uses native spellchecker APIs.

About this task
By default, macOS detects the language the user is typing in and automatically adjusts its internal
spellchecker. Use theses steps to select a specific language for spellchecking.

Procedure
1. Open System Preferences application
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2. On the System Preferencesmain window, select Keyboard option

System Preferences window switches to:
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3. On the Keyboard panel, select the Text tab

Keyboard preferences changes to:
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4. Select your preferred language from the Spelling drop-down list

What to do next
You may need to restart Swordfish to activate the new settings.

Spellchecking on Windows and Linux
OnWindows and Linux, spellchecking is based onHunspell dictionaries from the Chromiumproject.

About this task
Swordfish automatically downloads and installs dictionaries for your target language when they
are available at the Chromium project. Use these steps to adjust Swordfish's default language
settings.

Procedure
1. Select Settings → Preferences from the main menu.

The Preferences dialog appears:
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2. Select the Spellchecker tab.

Preferences dialog switches to:

3. If your target language is English, Portuguese or Spanish, select the default variant used
for spellchecking using the appropriate drop-down selector.

4. If you want to verify that your target language is supported for spellchecking, click on the
Available Spellchecker Languages button to display a list of supported languages.

The following dialog appears:

5. Click on the Save Preferences button to save your changes.
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XML Filter Settings

About this task
Swordfish needs to know two things for working with XML files:

• How to locate the grammar rules and entities declared in an XML file, if any.

• What elements and attributes contain translatable text.

XML catalogs that follow the specification published at
https://www.oasis-open.org/committees/entity/spec-2001-08-06.html byOASIS are used to resolve
the location of XML DTDs and Schemas.

Special XML files are used to configure the elements and attributes that contain translatable text.
These files are used by the internal XML Filter to extract text for processing.

Procedure
1. On macOS, select Apple → Preferences → Settings on the menu or press [Cmd + ,].•

• On Windows or Linux main menu, select Settings → Preferences.

The Preferences dialog appears:

2. Select the Advanced tab.

Preferences dialog switches to:
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3. On the Advanced tab, select the XML Filter tab.

Preferences dialog switches to:

4. If you want to use a custom XML catalog, type its location on the Default Catalog text box or
click the Browse... button next to it for selecting a file from the file system.
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5. Use the buttons below the XML Filter Configuration Files table to manage configuration
files.

DescriptionOption

Create a new configuration fileAdd

Modify an existing configuration fileEdit

Remove selected configuration filesRemove

Copy a configuration file to the folder that contains XML Filter
settings

Import

Copy a configuration file to a new locationExport

Note
Youmust run theprogramas anAdministratoruser to change the configuration
files for the XML Filter on Microsoft Windows.

6. Click on the Save Preferences button to save your changes.

Add Configuration File
Follow these steps to create a new configuration file for the XML Filter

Procedure
1. In the XML Filter tab of the Advanced section of Preferences dialog, click the Add button.

The Add XML Filter Configuration dialog appears:

2. Type the name of the root element of your XML files in the Root Element Name text box. The
name of the root element is used to name the configuration file.

3. Click the Add XML Filter Configuration button.

Results
A new, empty, configuration file is added and the XML Filter Configuration Files table reflects
the changes.

Edit Configuration File
Follow these steps to configure the elements of a configuration file for the XML Filter
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Procedure
1. In the XML Filter Configuration Files table, select the file that you want to modify.

2. Click the Edit button.

The XML Filter Configuration dialog appears:

3. Use the buttons in the XML Filter Configuration dialog to update the configuration file.

For each element, specify:

The name of the element being configuredElement Name

Element Type • Segment: the selected element starts a new section of
translatable text.

• Inline: the selected element represents a change in
formatting options and does not start a new section of
translatable text.

• Ignore: the selected element and its children should be
ignored.

The kind of formatting represented by an element of Inline typeInline Type

A list of attributes that require translation, separated by ';'Translatable Attributes

Select whether all white space in an XML element must be
preserved.

Keep White Space

a. Click the Add Element button to add a new element to the configuration file.

The Element Configuration dialog appears:
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b. Click the Edit Element button to modify the properties of an existing element.

The Element Configuration dialog showing the existing values appears:

c. Click the Remove Selected Elements button to delete one or more selected elements
from the configuration file.

4. Repeat the previous step until all elements are properly configured.

Remove Configuration Files
Follow these steps to remove one or more configuration files for the XML Filter.

Procedure
1. In the XML Filter Configuration Files table, select the files you want to remove.

2. Click the Remove button.

A confirmation dialog appears.

Results
Selected files are removed an the XML Filter Configuration Files table reflects the changes.
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Import Configuration File
Follow these steps to restore custom configuration files for the XML Filter

About this task
After a fresh install or upgrade, you may need to import configuration files for the XML Filter
created in a previous version or in a different machine.

Procedure
1. In theXML Filter tab of theAdvanced section of Preferences dialog, click the Import button.
2. In the dialog that appears, select the file to import.

Export Configuration File
Follow these steps to backup new or modified configuration files for the XML Filter

About this task
After creating a custom configuration file, make a backup copy by exporting it to a safe location.

Important
Installing a new version of Swordfish onmacOS or Linux removes any customization
you may have. It is important to export your modified configuration files so you can
import them back after an update.

Procedure
1. In the XML Filter Configuration Files table, select the files you want to export.

2. Click the Export button.

A dialog for selecting the folder where to store exported configuration files appears.
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Configuration Options

Basic Settings
Follow these steps to configure your default language pair, theme colors and preferred font size
when translating.

Procedure
1. On macOS, select Apple → Preferences → Settings on the menu or press [Cmd + ,].•

• On Windows or Linux main menu, select Settings → Preferences.

The Preferences dialog appears:

2. Use theDefault Source Language drop-down to select the language your source documents
are written in by default.

3. Use theDefault Target Language drop-down to select the language intowhich you normally
translate.

4. Use the Theme drop-down to control the application's default appearance.

• Select SystemDefault to let your Operating System control the default text/background
color combination (this option is not supported in some Linux distributions).

• Select Dark to work with light text on dark background.

• Select Light to work with dark text on light grey background.

5. Use the Font Size drop-down to select the default size of the text used in the translation panel.

6. Click on the Save Preferences button to save your changes.

Advanced Settings
Follow these steps to configure segmentation options, terminology searches preferences and XML
Filter settings.

About this task
Swordfish ships with a set of segmentation rules in SRX format that supports 16 languages and
their variants. You can also select your own SRX file for processing your documents.
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An extensive XML catalog that supports the most common XML grammars and document types
is included in Swordfish. If youwork with custom versions of DITA or other special XML grammars,
you can select your own XML catalog file for processing your documents and configure the XML
Filter to handle the elements defined in your grammars.

Procedure
1. On macOS, select Apple → Preferences → Settings on the menu or press [Cmd + ,].•

• On Windows or Linux main menu, select Settings → Preferences.

The Preferences dialog appears:

2. Select the Advanced tab.

Preferences dialog switches to:
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3. If you want to change storage locations for your projects, memories or glossaries, enter the
desired paths on the Projects Folder,Memories Folder and Glossaries Folder text boxes or
click the associated Browse... buttons to select folders from the file system.

Avoid using folders that could be modified by other programs while you work.

4. If you want to use a custom SRX file for segmentation, type its location on the Default SRX
File text box or click the Browse... button next to it for selecting a file from the file system.

5. Select the Use Paragraph Segmentation checkbox if you prefer to translate complete
paragraphs instead of sentences.

6. Swordfish uses the content of the source columnby default for unconfirmed segments. Select
the Include Unconfirmed Segments when Exporting Translation checkbox if you want to
use any text that is in the target column, regardless of its state, when generating translated
documents.

7. By default, Swordfish looks for exact terms, ignoring letter case, when searching in glossaries.
Select the Fuzzy Term Searches checkbox to allow searching for terms using a similarity
threshold of 60%.

8. Select the Case Sensitive Term Searches checkbox to consider letter case differences when
searching for terms.

9. Select the Case Sensitive TM Matches checkbox to consider leter case differences when
retrieving TM matches from memories.

10. Click on the Save Preferences button to save your changes.
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Subscriptions
Swordfish is available in two modes:

• Source Code

• Yearly Subscriptions for installers and support

Source Code
Source code of Swordfish is free. Anyone can download the source code fromGithub.com, compile,
modify and use it at no cost in compliance with the accompanying license terms.

Subscriptions
The version of Swordfish included in the official installers fromMaxprograms Download Page can
be used at no cost for 30 days requesting a free Evaluation Key.

Personal Subscription Keys are available at Maxprograms Online Store. Subscription Keys cannot
be shared or transferred to different machines.

Subscription version includes unlimited direct email support at tech@maxprograms.com

Differences Summary

Subscription BasedSource Code

YesNoReady To Use
Installers

YesNoNotarized macOS
launcher

YesNoSigned launcher and
installer forWindows

NoneNoneRestricted Features

Technical Support • Direct email at
tech@maxprograms.com

• Peer support at Groups.io

• Peer support at Groups.io

First Registration - Evaluation Request

Procedure
1. When you open Swordfish from subscription installers for the first time, or when the

Subscription Key is not registered, the Register Subscription dialog is displayed:
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2. If you have a Subscription Key, type it in the Subscription Key text box and click the Register
Subscription button.

On registration success, the main editing screen will be presented.

3. If you don't have a Subscription Key and wish to test the program during 30 days, click the
Request Evaluation Key button.

The Request Evaluation Key dialog appears:

4. Enter the requested data and click the Request Evaluation Key button.

On success, an email with the requested Evaluation Key will be sent to the indicated address
and the following dialog will be displayed:

Check your email and register the Evaluation Key using the instructions shown above.

Subscription Renewal

About this task
You can register a new subscription key before your existing subscription expires.
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Procedure
1. Select Help → Register Subscription... from the main menu.

The Register Subscription dialog appears:

2. If you don't have a subscription key yet, click on the Purchase Subscription button to open
Maxprograms Online Store on your internet browser.

3. If you have a Subscription Key, type it in the Subscription Key text box and click the Register
Subscription button.

On registration success, the following dialog appears:
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Licenses
Swordfish

• Available from https://www.maxprograms.com/products/swordfish.html

• Published under Eclipse Public License 1.0

Electron

• Available from https://www.electronjs.org/

• Published under MIT License

Java SE

• Available from https://adoptium.net/

• Published under GPL2 with the Classpath Exception

OpenXLIFF Filters

• Available from https://www.maxprograms.com/products/openxliff.html

• Published under Eclipse Public License 1.0

XMLJava

• Available from https://github.com/rmraya/XMLJava

• Published under Eclipse Public License 1.0

BCP47J

• Available from https://github.com/rmraya/BCP47J

• Published under Eclipse Public License 1.0

DTDParser

• Formerly available from http://wutka.com/dtdparser.html

• Published under two licenses: Apache Style License and LGPL 2.1

JSON-java

• Available from https://github.com/stleary/JSON-java

• Published under a custom license

jsoup

• Available from https://jsoup.org

• Published under MIT License

MapDB

• Available from https://mapdb.org

• Published under Apache License

SQLite

• Available from https://sqlite.org/

• Released to Public Domain
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MTEngines

• Available from https://github.com/rmraya/MTEngines

• Published under Eclipse Public License 1.0

TypesBCP47

• Available from https://github.com/rmraya/TypesBCP47

• Published under Eclipse Public License 1.0

TypesXML

• Available from https://github.com/rmraya/TypesXML

• Published under Eclipse Public License 1.0
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Glossary
Auto-Translation

Auto-Translation is a language technology that assembles translations combining
fragments from Translation Memory results and glossary entries.

Computer Aided Translation (CAT)
Computer technology application designed to assist human translators in the translation
process.

Character Set
A character set (sometimes referred to as code page) is a collection of characters that are
associated with a sequence of natural numbers in order to facilitate the storage of text
in computers and the transmission of text through telecommunication networks.

Inline Tags
Inline tags are special codes that represent formatting information from the original
document that is embedded in a segment.

Machine Translation
A technology that automatically translates text from one language to another using
previously defined grammar rules, glossaries, statistic analysis and other methods.

Regular Expression
Formula or expression that describes text strings using a specially defined syntax. See
https://en.wikipedia.org/wiki/Regular_expression.

RemoteTM
RemoteTM is an open source TranslationMemory (TM) server with an open REST API that
allows sharing memories and glossaries over the Internet.

SRX
Segmentation Rules eXchange (SRX) is an XML-based open standard, originally published
by LISA (Localization Industry Standards Association), for describing how translation and
other language-processing tools segment text for processing.

TBX
TBX (TermBase eXchange) is an open XML-based standard for exchanging structured
terminological data. TBX version 2, also known as ISO 30042:2008, was originally released
in 2002 by LISA's OSCAR special interest group. TBX version 3, also known as ISO
30042:2019, is the latest release published by ISO.

TMX
Translation Memory eXchange (TMX) is an open standard originally published by LISA
(Localization Industry Standards Association). The purpose of TMX is to allow easier
exchange of translationmemory data between tools and/or translation vendors with little
or no loss of critical data during the process.

Translation Memory
TranslationMemory (TM) is a language technology that enables the translation of segments
(paragraphs, sentences or phrases) of documents by searching for similar segments in
a database and suggesting matches that are found in the databases as possible
translations.

Source Language
The language of a document that is to be translated.
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Target Language
The language into which a document is being translated.

XLIFF
XLIFF (XML Localization Interchange File Format) is an open standard developed byOASIS
(Organization for the Advancement of Structured Information Standards). The purpose
of this vocabulary is to store localizable data and carry it from one step of the localization
process to the other, while allowing interoperability between tools.
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